JOSSO

Support SSL in agent back channel

Details

  • Type: Improvement Improvement
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Duplicate
  • Affects Version/s: JOSSO 1.8.5
  • Fix Version/s: JOSSO 1.8.5
  • Component/s: ISAPI Agent
  • Labels:
    None
  • Environment:
    agent running on Windows 2003 Server, IIS 6, gateway running on Weblogic 10.2

Description

The ISAPI agent won't make web services calls to the gateway over SSL. The "gatewayEndpoint" variable in the .ini file can only contain a server and port number combination. The "http" protocol is always prepended, along with the web service context, therefore I cannot communicate with the gateway securely.
It would be nice if you could specify a scheme, host and port combination for the "gatewayEndpoint". SSL communication can be done with free OpenSSL libraries.

Activity

Goran Nastov added a comment -
This issue is duplicate of JOSSO-245 which is currently in progress.

People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved: